# 在Google Sheets打开Excel文件 & 保存为.xlsx

> 在Google Sheets编辑Excel文件、把它转换成Google Sheets格式、导入CSV数据，以及把任何电子表格下载为Excel（.xlsx）文件。
>
> Source: https://docs.officeniaga.com/zh/sheets-excel/

你不用安装Excel，也能在Google Sheets打开、编辑和分享Excel文件。完成后，可以把任何电子表格下载为Excel文件。

## 打开Excel文件

先把文件上传到Google Drive。如需帮助，请看[在Google Drive上传文件 & 整理文件夹](/zh/drive-upload-organise/)。

1. 在[Google Drive](https://drive.google.com)里，双击Excel文件。

   *(Screenshot: My Drive列表里已标示的Excel文件)*

2. 文件会在Google Sheets打开，名字旁边有<strong>.XLSX</strong>标志。这表示它仍然是Excel文件。

   *(Screenshot: Google Sheets里文件名旁边的XLSX标志)*

3. 像平常一样编辑。更改会以Excel格式保存。

## 把Excel文件转换成Google Sheets

转换会另外创建一份Google Sheets副本，原本的Excel文件保持不变。

1. 在Google Sheets打开Excel文件。
2. 点击**File** → **Save as Google Sheets**。

   *(Screenshot: File菜单，已标示Save as Google Sheets)*

3. Google Sheets会创建一份Google Sheets格式的副本并打开它。从现在起，请在这份副本里工作。

   *(Screenshot: 没有XLSX标志的Google Sheets副本)*

有些东西不会保留下来。宏不能运行，连接到其他Excel工作簿的链接会失效，Excel里锁定或隐藏的单元格会变成可以编辑。

## 把数据导入电子表格

用**Import**把Excel或CSV文件导入你已有的电子表格，例如银行月结单或导出的销售数据。

1. 打开你要放数据的Google Sheet。
2. 点击**File** → **Import**，然后上传或选择文件。

   *(Screenshot: File菜单，已标示Import)*

   *(Screenshot: Import file窗口，显示Upload标签页和可选择的文件)*

3. 选择数据要放在哪里：
   - **Create new spreadsheet**
   - **Insert new sheets**
   - **Replace spreadsheet**
   - **Replace current sheet**
   - **Append rows to current sheet**
   - **Replace data starting at selected cell**

   *(Screenshot: Import location列表里的六个选项)*

4. 如果是CSV或文本文件，**Separator character**保持**Detect automatically**，除非各列的数据显示不对。
5. 点击**Import**。

   *(Screenshot: Import file窗口和Import data按钮)*

## 下载为Excel

如果有人需要Excel格式的文件，就下载一份副本。

1. 打开电子表格。
2. 点击**File** → **Download**。
3. 选择**Microsoft Excel (.xlsx)**。你也可以选择<strong>PDF (.pdf)</strong>或**Comma Separated Values (.csv)**。

   *(Screenshot: File → Download，已标示Microsoft Excel (.xlsx))*

文件会下载到你的电脑。Drive里的文件不会改变。

## 还有问题？

请通过WhatsApp联系我们的支持团队：[+60 16-916 3324](https://wa.me/60169163324)。

## 常见问题

### 我的Excel宏（macro）不能用，为什么？

Google Sheets不能运行Excel宏（VBA）。依赖宏的文件请继续用Excel，或请你的IT人员用Google Apps Script重新制作这个宏。

### Excel文件里锁定的单元格，在Sheets里却可以编辑，为什么？

Excel的工作表和工作簿保护不会保留下来。转换之后，请用Data → Protect sheets and ranges重新设置保护。请看创建Google Sheet、分享 & 保护单元格 (/zh/sheets-basics-share/)。

### 文件应该保留为Excel，还是转换？

如果你要和用Excel的人来回传送这个文件，就保留为Excel。如果你的团队会在Google Sheets里处理它，就转换，因为受保护的范围、Gemini和其他一些功能只能在Google Sheets文件里使用。
